スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

プリントサーバ(Mini-102M)のトラブル

久しぶりに客先でプリントサーバ(Mini-102M)にハマりました。
いつものように数年前に営業が導入した物の後始末ですが。。。

お値段は安いですが、、、kakaku.comのレビューを見る限り、安かろう悪かろうの代表例です。
Mini-102M 価格比較
最安価格(税込):\3,658
定価:\7,800(税込)
満足度1.84って。。。

意味不明な状況なので何回も電話対応できないと判断し、2回目で現地障害対応をしてきました。

4台のPCからすべて印字がエラーになるとの事だったので、真っ先にHUBの電源の入れ直しをした所、1回目の印字は遅いながらも成功しましたが、、、2回目以降はプリンタドライバーを入れ直ししても印刷できず。。。

利用環境はこんな感じです。(※PCはWindowsXPが4台)
プリンタ      プリントサーバ
[PX-101]--USB--[Mini-102M]==LAN==[HUB]==LAN==[PC]

そもそも普通にWindowsの標準TCP/IPポート設定で印刷すれば使えると思い込んでいたのがハマリの原因でした。

・Windowsの標準TCP/IPポートの再作成でもダメ!
・PX-101のドライバを入れ直してもダメ!
・Windowsファイアウォールを無効にしてもダメ!
・新規購入して持参した同製品と交換してもダメ!
・Mini-102MとPCを直結してもダメ!

ここでようやくMini-102Mのオンラインマニュアルを見ました。

まずは以下のツール設定をやってみました。
5.ドライバ&ユーティリティのインストール
ところが、、、このツールで設定してプリントサーバの設定をするとLAN経由なのにポートが[USB virtual printer port]として認識されました???
色々いじっていくうちに何となく仕組みが分かりましたが、非常にクセのあるツールです。
どうもこのツールで接続した場合、利用できるのは1対1のみですが双方向通信できて印刷開始まで数秒程度というメリットがあります。しかも接続終了後にプリンタをオフラインにするような設定もありました。
しかし、複数台のPCからこの運用をしようとすると、他のPCが接続していると必ず印刷が失敗します

これをお客様に説明するのはあまりに無理があるので、他の方法がないかさらに探してみました。

すると・・・以下情報がありました。
■トラブルシューティング>パソコンから印刷できない
 ↓
本製品は、Windows Vista/XP/2003/2000で4.ドライバ&ユーティリティのインストールの手順で設定したとき以外は、双方向通信に対応していません。

■印刷方法>Windows Vista/XP/2003/2000の単方向通信設定>Windows XP/2003/2000編
 ↑
結局・・・この方法で設定すれば複数台接続がエラーなく完了しましたが、印刷開始まで約15~20秒程度かかってしまいます。
何とか解決しましたが、この製品・・・何かきつねに騙されたような気分です。

以下製品仕様の注意事項を見て、騙されたと我に返りました。。。

Mini-102M>製品仕様
 ▲プリンタとの双方向通信は付属ユーティリティをインストールしたWindows Vista/XP/2000/Sever 2003 並びに、Mac用付属ユーティリティをインストールした Mac OS X 10.4/10.5のみサポートします。
 ▲双方向通信利用時は同時に1台のコンピュータだけがプリンタを使用できます。
スポンサーサイト

LS-WTGLの復旧作業

先日バックアップ目的で、LS-W1.0TGL/R1のRAID1構成のHDDをコールド状態で引き抜いて別LS-W1.0TGL/R1に換装してRAID1のリビルドを行ったのですが、どちらのNASもリブートするとErrorランプ6回点滅の致命的エラー(※今回の場合はソフトウェアRAID構成情報破損だと思われる。)が発生して全く起動しなくなってしまいました。

折角冗長化目的で同じNASを揃えていたのに自爆。。。
大事なデータがあるので何とか方法がないかと、Google先生に助けを求めてもつれないお返事。。。

→「LinkStation、DIAGランプ6回点滅で故障
→「データ復旧事例:NAS(LinkStation/TeraStation/LANDISK)復旧

さすがにデータ復旧会社に100万円?も投資するほどお金もないので、ここは意地でも技術力で何とかするぞとがんばってみました!

まずはLinkStationの仕組みを理解しようと色々Google先生に教えを乞いました。

以前やった事がある「基板が壊れたLinkStation HD-HG250LANのHDDの中身をKNOPPIXで吸い出す」の手順だとファイルやフォルダが文字化けする上に時間がかかるので、もう少し根本的な解決方法がないか考えてみました。

前回紹介したサイトの先人達がLinkStationのHDD換装をしている手順にヒントがあると思い、まず新品HDD2台用意してその手順をやってみる事にしました。
→「Linkstation LS-W1.0TGL/R1 1TB*2台に換装 RAID1

その結果、ファームウェアをTFTPでLinkstationにアップロードする事でソフトウェアRAID構成やカーネル展開をしてセットアップをしている事に気づきました。

そこで考えたのが、RAID1構成の一方のHDD情報が正常ならカーネル再展開で修復するかもしれないという仮定でした。

以下仮定を検証しながら復旧した結果をご報告します。
ただし必ずしも上手くいくとは限らないので、あくまで自己責任で。。。

【復旧作業】
Linkstation LS-W1.0TGL/R1 1TB*2台に換装 RAID1」、「バッファロー NAS HDD換装まとめ」を参考にしながら作業を進めます。
※以下はRAID1を前提とします。

①RAID1を構成していた時に正常稼動していたHDDはそのままのスロットに残す。

②パーティション情報のない同型番のHDDを空スロットに装着。

③バッファローから最新ファームをダウンロードしてuImage.buffaloinitrd.imgを取り出す。
 (※現バージョンが最新の場合は、ダウンロードファイルの「LSUpdater.ini」の「VersionCheck = 1」の部分を「VersionCheck = 0」に書き換えることでファームウェアの上書きができます。)

initrd.imgの拡張子をzipに変更して解凍(要パスワード)し、中からinitrd.buffaloを取り出す。
 (※v1.09、1.10βは「IeY8omJwGlGkIbJm2FH_MV4fLsXE8ieu0gNYwE6Ty」で解凍できました。違ってたら「Linkstation password」で検索しましょう。)

⑤新規フォルダ(例、C:\LS-WTGL)を作成し、中にuImage.buffaloinitrd.buffaloをコピーする。

⑥フリーウェアのTFTPDをダウンロードする。

⑦PCのIPアドレスを 192.168.11.1 に変更してTFTPDを起動する。

⑧タスクバーにTFTPDのアイコンが常駐するので、右クリックして設定画面を出して先ほど新規作成したフォルダのパスを指定する。

⑨クロスLANケーブルかHUB経由でNASとPCを接続して電源スイッチを入れ、同じようにErrorランプ6回点滅したら、初期化スイッチを楊枝とかで押すとエラーランプが消えて正常状態のランプになる。
 (※TFTPDの常駐アイコンが反応するので、WireSharkでパケットキャプチャをすると色んなパケットが飛んでいるのが分かります。)

⑩TFTPDの常駐アイコンが反応しなくなったら「NAS Navigator 2」で LS-W1.0TGL/R1を再検索します。IPアドレスを変更するように聞いてきますが、無視してPCのIPアドレスを以前利用していたネットワークに変更します。

⑪再度「NAS Navigator 2」で LS-W1.0TGL/R1を再検索して、Webコンソールに以前と同じ認証でアクセスします。

⑫この段階までくればWindowsネットワーク上で以前の共有フォルダが見えているので、LS-W1.0TGL/R1の電源を落としたり再起動せずにファイルコピーをしておきます。
 (※バックアップさえとれれば工場出荷時に戻す事もできるので、後悔する前に必ずやっておきましょう!)

⑬ファームウェアを上記③の手順を利用して異なるバージョンに変更します。
 (※最新にできない場合は③の手順を利用して旧バージョンのファームウェアを使ってダウングレードします。同バージョンのファームウェアの上書きだとRAID1が再認識されないため、この作業をせずにNASを再起動するとErrorランプ6回点滅に逆戻りとなります。)

⑭NASを再起動するとRAIDアレイ1障害状態となるので、WebコンソールよりRAIDアレイ1の復旧処理を行えば完全復旧となります。

LS-WTGLのFWアップグレード不具合

先日LS-W1.0TGL/R1を購入してデータ移行が無事完了したので、つい調子に乗ってFW(1.09→1.10β)のアップグレードをしました。

Buffaloのサイトを見ながらFWのアップグレード自体は成功したのですが・・・
アップグレード後にNASにアクセスしようとすると、「権限がありません。」と怒られてしまいデータにアクセスできなくなってしまいました。

Webコンソールはアクセスできたので、ネットワーク周りを色々変更してみたのですが改善せず。

そこで何とかFWをダウングレードできないかと、Google先生に問い合わせるとGoodな返答がありました。

■kakaku.comのレビュー(HDD換装について)より

ファームウェアを「Ver.1.09」にダウングレードすることで、不具合が解消されました。
ダウングレードをするには「Ver.1.09」のアップデータフォルダ内にある
LSUpdater.ini」の「VersionCheck = 1」の部分を「VersionCheck = 0
に書き換えることで可能です。


さすがにtelnetアクセスよりは敷居が低いので、自己責任上等でやってみた所上手く行きました。

これからは安易にFWのアップグレードは止めようと思いました(T_T)

HDD換装をしている人もいるみたいです。
 ↓
Linkstation LS-W1.0TGL/R1 1TB*2台に換装 RAID1

もっと勉強しないと。。。
プロフィール

kitabomb

Author:kitabomb
田舎のしがないSI屋です。

日記

検索フォーム
カテゴリ
最新記事
RSSリンクの表示
ブロとも申請フォーム

この人とブロともになる

QRコード
QRコード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。